Hi…

Kali ini kita akan mecoba install php5(5.6) di Ubuntu 16.04. Kasus ini terjadi pada saat saya upgrade dari ubuntu 14.04 ke 16.04 dimana paket php5(5.6) diremove oleh system.

Saya coba cek php nya, ternyata belum terinstall dan php yang tersedia cuma php 7

$ sudo apt-get install php5-cli
Cependant les paquets suivants le remplacent :
  php7.0-cli:i386 php7.0-cli`

List semua packages php dengan command :

dpkg -l | grep php| awk '{print $2}' |tr "\n" " "

kemudian remove packages yang tidak digunakan dengan command :

sudo aptitude purge your_packages_here

atau jika ingin me remove langsung
keseluruhan gunakan command :

sudo apt-get purge `dpkg -l | grep php| awk '{print $2}' |tr "\n" " "`

Selanjutnya tambahkan PPA

sudo add-apt-repository ppa:ondrej/php

Install PHP Version

sudo apt-get update
sudo apt-get install php5.6

Anda dapat menginstall php5.6 modules juga, misal

sudo apt-get install php5.6-mbstring php5.6-mcrypt php5.6-mysql php5.6-xml

Selanjutnya verify versi php nya. Jika sudah install php5.6-cli, gunakan command

php -v

Jika belum, bikin file dengan extensi php, masukkan kode dibawah kedalam file nya

<?php phpinfo();

Tambahan, pada wordpress yg saya coba, belum support php7, jadi terpaksa saya downgrade ke php5

 

 

 

 

Leave a Reply