Hi…

Kali ini kita akan mencoba VPN site to site menggunakan IPSec, langsung aja ya…

Pertama enable dulu logging nya di MikroTik untuk memudahkan troubleshoot dengan melihat log

/system logging
add topics=ipsec

Kemudian, jangan lupa untuk mengamankan Router, dengan men-disable service yang tidak akan digunakan dalam mengakses Router

/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set api disabled=yes
set api-ssl disabled=yes

Langkah selanjutnya adalah Set IP addressnya

R1

/ip address
add address=1.1.1.2/24 interface=ether2 network=1.1.1.0
add address=192.168.4.1/24 interface=ether3 network=192.168.4.0

R2

/ip address
add address=2.2.2.2/24 interface=ether1 network=2.2.2.0
add address=192.168.2.1/24 interface=ether2 network=192.168.2.0

Kemudian set default route, firewall nat dan dns nya

R1

/ip route
add distance=1 gateway=1.1.1.1

/ip firewall nat
add action=accept chain=srcnat dst-address=192.168.2.0/24 src-address=\
192.168.4.0/24
add action=masquerade chain=srcnat out-interface=ether2

/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

 

R2

/ip route
add distance=1 gateway=2.2.2.1

/ip firewall nat
add action=accept chain=srcnat dst-address=192.168.4.0/24 src-address=\
192.168.2.0/24
add action=masquerade chain=srcnat out-interface=ether1

/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

Selanjutnya, baru set IPSec nya

R1

/ip ipsec proposal
set [ find default=yes ] auth-algorithms=md5 enc-algorithms=3des

/ip ipsec peer
add address=2.2.2.2/32 enc-algorithm=3des hash-algorithm=md5 secret=\
1234
/ip ipsec policy
add dst-address=192.168.2.0/24 ipsec-protocols=ah-esp sa-dst-address=\
2.2.2.2 sa-src-address=1.1.1.2 src-address=192.168.4.0/24 \
tunnel=yes

R2

/ip ipsec proposal
set [ find default=yes ] auth-algorithms=md5 enc-algorithms=3des

/ip ipsec peer
add address=1.1.1.2/32 enc-algorithm=3des hash-algorithm=md5 secret=\
1234
/ip ipsec policy
add dst-address=192.168.4.0/24 ipsec-protocols=ah-esp sa-dst-address=\
1.1.1.2 sa-src-address=2.2.2.2 src-address=192.168.2.0/24 \
tunnel=yes

Penjelasannya adalah sebagai berikut :

Auth Algorithma menggunakan md5 dengan enkripsi algorithma menggunakan 3des. Sedangkan secret atau password untuk kedua router harus sama, disini menggunakan secret=1234

Ok, sudah jadi, silahkan set IP dimasing masing PC dan coba ping ke network disebelahnya

 

 

Leave a Reply