Hi…

Dapet tugas dari kantor untuk buat VPN Point to Site untuk network internal kantor, untuk menghemat waktu dan budget saya coba menggunakan MikroTik. Ok, kita mulai ya…

Pertama tambahkan logging untuk ipsec dan l2tp, tujuannya agar mudah trace pada saat troubleshoot

/system logging
add topics=ipsec
add topics=l2tp

Selanjutnya seting ip address di interface yang digunakan :

/ip address
add address=1.1.1.2/24 interface=ether2 network=1.1.1.0
add address=172.16.0.1/16 interface=ether12 network=172.16.0.0

Selanjutnya set default route, firewall nat dan dns supaya bisa komunikasi keluar

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether2

/ip route
add distance=1 gateway=1.1.1.1

/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

Selanjutnya set dhcp server dan pool yang nanti digunakan untuk vpn client nya

/ip dhcp-server network
add address=172.16.0.0/16 dns-server=8.8.8.8 gateway=172.16.0.1

/ip pool
add name=dhcp_pool1 ranges=172.16.255.2-172.16.255.254

/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=eth12 name=dhcp1

Nah sekarang, masuk kebagian L2TP nya. Buat interface

/interface l2tp-server
add name=VPN user=""

Selanjutnya enable L2TP Server  dan IP Sec pada L2TP Servernya

/interface l2tp-server server
set enabled=yes ipsec-secret=1234 use-ipsec=yes

Kemudian create profile nya

/ppp profile
set *0 dns-server=8.8.8.8,8.8.4.4 local-address=172.16.0.1 remote-address=\
dhcp_pool1
set *FFFFFFFE local-address=172.16.0.1 remote-address=dhcp_pool1

Kemudian, buat user yang nanti akan menggunakan / dial vpn service

/ppp secret
add name=konfigurasi password=1234 profile=default-encryption

Lanjut lagi sekarang masuk kebagian IPSec nya, karena tadi pada saat seting L2TP Server udah di “yes” kan pada ipsec nya, otomatis akan tercreate IPSec peer baru, kita gak usah repot2 bikin IPSec peer. Yang kita lakukan hanya edit bagian proposal dan menghilangkan “default”pada Policy Group

/ip ipsec policy group
set
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des

Untuk mengamankan MikroTik, lebih baik disable service-service yang jarang atau tidak digunakan untuk mengaksesnya

/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set api disabled=yes
set api-ssl disabled=yes

Terakhir, jangan lupa set waktunya ya

/system clock
set time-zone-name=Asia/Jakarta

Sekarang kita set di sisi client, saya menggunakan windows 10

vpn1 vpn2

Setelah itu, klik Save, kemudian kita coba connect, dan hasilnya bisa connectedvpn3

Kita coba ping ke gateway nya

vpn4

Leave a Reply