Hi…

Sekarang kita coba loadbalance metode ECMP (Equal Cost Multi Path) di router MikroTik. Kira-kira seperti ini topologi nya

Seperti biasa, saya anggap pembaca web ini sudah bisa konfigurasi dasar mikrotik, jadi saya langsung ke point-point penting nya ya.

Pertama, set dulu ip address nya

/ip address
add address=192.168.20.44/24 interface=ether1-isp1 network=192.168.20.0
add address=192.168.30.44/24 interface=ether5-isp2 network=192.168.30.0
add address=10.0.4.1/24 interface=ether4-lan network=10.0.4.0

Setelah itu, buat NAT nya. Karena ada 2 ISP, jadi dibuat 2 NAT dengan out interface berbeda

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1-isp1
add action=masquerade chain=srcnat out-interface=ether5-isp2

Selanjutnya, buat mark mangle nya untuk menandai traffik, agar koneksi outgoing router tetap melalui interface yang sama dengan interface trafik incomingnya

/ip firewall mangle
add action=mark-connection chain=input in-interface=ether1-isp1 \
new-connection-mark=isp1_conn
add action=mark-connection chain=input in-interface=ether5-isp2 \
new-connection-mark=isp2_conn
add action=mark-routing chain=output connection-mark=isp1_conn \
new-routing-mark=to_isp1
add action=mark-routing chain=output connection-mark=isp2_conn \
new-routing-mark=to_isp2

Terakhir, buat default route nya dan pasang routing mark nya dimasing-masing gateway

/ip route
add distance=1 gateway=192.168.20.1 routing-mark=to_isp1
add distance=1 gateway=192.168.30.1 routing-mark=to_isp2
add check-gateway=ping distance=1 gateway=192.168.30.1,192.168.20.1

Hasil trace route

Traceroute ketika interface ether5-isp2 di disable

Apabila, kedua ISP nya memiliki bandwidth yang berbeda, dan kita ingin kita bisa membuat perbandingan untuk membagi beban bandwidth. Misal ISP1 memiliki 1Mbps dan ISP2 memiliki 2 Mbps , memiliki perbandingan 1:2. Hal ini bisa menambahkan gateway, seperti berikut :

Kelemahan dari ecmp ini, apabila kedua ISP memiliki DNS yang berbeda, dan menggunakan DNS salah satu ISP,  maka pada saat salah satu down,  koneksi internet akan mati. Solusi nya adalah menggunakan DNS lain yang bisa digunakan bersama-sama oleh kedua ISP tersebut. Atau bisa juga dengan memasang semua DNS kedua ISP.

Leave a Reply