Install Nextcloud di Ubuntu 16.04

Hi…

Kali ini kita akan coba install nextcloud. Apa itu nextcloud? yaitu aplikasi share file semacam GoogleDrive atau Dropbox dimana servernya bisa dibuat sendiri di onpremise. Jadi nanti akan punya Layanan filesharing semacam GoogleDrive atau Dropbox dengan mesin server kita sendiri. Keren ya??

OK,, sekarang mulai ya prosesnya

Update dulu repo dan package pada Server Ubuntu

# apt update & apt upgrade -y

Install Package-package yang diperlukan

# apt-get install apache2 mariadb-server libapache2-mod-php7.0
# apt-get install php7.0-gd php7.0-json php7.0-mysql php7.0-curl php7.0-mbstring
# apt-get install php7.0-intl php7.0-mcrypt php-imagick php7.0-xml php7.0-zip

Download aplikasi nextcloud, key gpg, md5

# wget https://download.nextcloud.com/server/releases/nextcloud-14.0.3.zip
# wget https://download.nextcloud.com/server/releases/nextcloud-14.0.3.zip.md5
# wget https://download.nextcloud.com/server/releases/nextcloud-14.0.3.zip.asc
# wget https://nextcloud.com/nextcloud.asc

Verifikasi MD5 sum

# md5sum -c nextcloud-14.0.3.zip.md5 < nextcloud-14.0.3.zip

Verifikasi PGP Signature

# gpg --import nextcloud.asc
# gpg --verify nextcloud-14.0.3.zip.asc nextcloud-14.0.3.zip

Install Unzip untuk ekstrak file nextcloud yang sudah kita download

# apt install unzip

Ekstrak file nextcloud

# unzip nextcloud-14.0.3.zip

Copy hasil ekstrak tadi ke document root

# cp -r nextcloud /var/www/

Ubah owner direktori nextcloud

# chown -R www-data:www-data /var/www/nextcloud/

Buat apache configuration nya

# nano /etc/apache2/sites-available/nextcloud.conf

Isikan dengan dibawah ini

Alias /nextcloud "/var/www/nextcloud/"

<Directory /var/www/nextcloud/>
Options +FollowSymlinks
AllowOverride All

<IfModule mod_dav.c>
Dav off
</IfModule>

SetEnv HOME /var/www/nextcloud
SetEnv HTTP_HOME /var/www/nextcloud

</Directory>

Enable nextcloud.conf nya, kemudian reload servis apache

# a2ensite nextcloud
# service apache2 reload

Enable apache mod yang diperlukan untuk nextcloud, kemudian reload kembali service apache

# a2enmod rewrite
# a2enmod headers
# a2enmod env
# a2enmod dir
# a2enmod mime
# service apache2 reload

Sekarang kita masuk kebagian database, jalankan perintah dibawah untuk mengamankan mariadb server

# mysql_secure_installation

Isikan seperti berikut

Enter current password for root (enter for none): Just press the Enter
Set root password? [Y/n]: Y
New password: Enter password
Re-enter new password: Repeat password
Remove anonymous users? [Y/n]: Y
Disallow root login remotely? [Y/n]: Y
Remove test database and access to it? [Y/n]: Y
Reload privilege tables now? [Y/n]: Y

Kemudian, buat database, user dan password untuk nextcloud. Disini saya buat nama db nextcloud, user konfigurasi.net dan password 12345678

[email protected]:/home/ubuntu# mysql -u root -p
Enter password:
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 32
Server version: 10.0.36-MariaDB-0ubuntu0.16.04.1 Ubuntu 16.04

Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> create database nextcloud;
Query OK, 1 row affected (0.00 sec)
MariaDB [(none)]> create user 'konfigurasi.net'@'localhost' identified by '12345678';
Query OK, 0 rows affected (0.00 sec)
MariaDB [(none)]> grant all on nextcloud.* to 'konfigurasi.net'@'localhost' identified by '12345678' with grant option;
Query OK, 0 rows affected (0.00 sec)
MariaDB [(none)]> exit
Bye

Selanjutnya, masuk ke browser, ketikkan http://<ipaddress>/netxtcloud.

Buat akun admin dan passwordnya, isikan lokasi data folder, kemudian isi database, user db dan password db. Terakhir klik Finish Setup

Apabila berhasil akan muncul seperti gambar berikut, klik next dan next saja

Nextcloud sudah berhasil, untuk cara penggunaannya bisa download file Nextcloud Manual yang sudah disediakan didalam aplikasi yang sudah dibuat tadi.

Selanjutnya nanti kita akan menghubungkan dengan server dokumen, yang fungsinya nanti akan dapat membuka dokumen office di browser, seperti pada Google Cloud. Tapi akan dilanjut dihalaman lainnya ya….

Terima Kasih

Bahan belajar

Save MikroTik Logs to Remote Syslog Server

Hi…

Kali ini, kita akan coba untuk menyimpan/melempar log-log yang ada di MikroTik ke Syslog Server yang kali ini menggunakan Ubuntu server 14.04.5.

IP MikroTik : 192.168.65.136/24

IP Ubuntu Server : 192.168.65.131/24

Konfigurasi di MikroTik

Command Line

/system logging action
set 3 remote=192.168.65.131

/system logging
add action=remote topics=critical
add action=remote topics=info

WinBox

 

 

Sekarang Konfigurasi di Ubuntu Server
Pertama install dulu paket syslog-ng

apt-get install syslog-ng-core

Kemudian edit file syslog-ng.conf nya

vi /etc/syslog-ng/syslog-ng.conf

Tambahkan konfigurasi berikut

# Accept connection on UDP
source s_net { udp (); };

# MIKROTIK ###########
# Add Filter to add our mikrotik
filter f_mikrotik { host( "192.168.65.136" ); };
# Add destination file where logs will be stored
#destination df_mikrotik { file("/var/log/mikrotik.log"); };
log { source ( s_net ); filter( f_mikrotik ); destination ( df_mikrotik ); };
destination df_mikrotik {
 file("/var/log/mikrotik/mikrotik.${YEAR}.${MONTH}.${DAY}.log"
# template("${HOUR}:${MIN}:${SEC} ${HOST} ${MSG} ${MSG}\n")
 template-escape(no));
};

Simpan file yang telah di edit. Setelah itu buat di direktori mikrotik di var/log

 mkdir /var/log/mikrotik/

Jangan lupa allow port 514 di iptables

 iptables -A INPUT -p udp --dport 514 -j ACCEPT

Restart service syslog-ng nya

 service syslog-ng restart

Sekarang, kita coba monitor apakah logs sudah mau tersimpan diserver

 tail -f /var/log/mikrotik/mikrotik.2017.01.30.log

Nah… sudah bisa kan…

Sekarang kita set log rotate nya agar bisa delete otomatis log nya

 vi /etc/logrotate.d/syslog-ng

Tambahkan script berikut

/var/log//mikrotik/*.log {
 daily
 rotate 90
 missingok
 compress
 notifempty
 missingok
 sharedscripts
 /etc/init.d/syslog-ng restart
 endscript
# invoke-rc.d syslog-ng reload > /dev/null
}

Berikut penjelasannya:

daily : the logrotation for mikrotik log in /var/log/mikrotik/mikrotik.log file will be don eon daily basis. this value describes the interval of rotation
rotate 90 : means syslog will keep 90 log file. [number of files]
compress : log file will be compressed using the gzip format
missingok : avoids halting on any error
notifempty : will not rotate log file if its empty

Jangan lupa restart service syslog-ng nya

 service syslog-ng restart

Terakhir kita set cron nya agar jalan pada jam 00.00, edit file /etc/crontab

0 0     * * *   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )