Konfigurasi Data Nusantara

MikroTikNetworking

VLAN pada MikroTik

Hi…

Dalam switching teknologi, memiliki tiga mode vlan: Access, Trunk dan Hybrid.

Access port digunakan pada paket untagged, yaitu semacam port untuk menghubungkan PC Anda ke switch.

Trunk port mampu menerima dan meneruskan paket tagged dari beberapa VLAN. Yang satu ini adalah untuk menghubungkan switchs.

Port Hybrid merupakan mode khusus yang memungkinkan paket untagged dan tagged ada pada port yang sama. Bayangkan bahwa kita memiliki telepon Voip desktop, dan akan menghubungkan PC ke telepon dan telepon ke switch. Kita akan memiliki tagged vlan untuk voip dan data untagged untuk PC.

Yang harus diperhatikan/diingat pada Interface vlan pada perangkat Mikrotik adalah “menambahkan tag pada egress / menghapus tag dari ingress”.

Ok, sekarang kita coba lab kan seperti pada gambar berikut

Pada mikrotik-1, interface ether1 access port dengan vlan 10, ether2 access port dengan vlan 20 dan ether4 merupakan trunk port yang melewatkan vlan 10 dan vlan 20

Pada mikrotik-2, interface ether1 access port dengan vlan 10, dan ether4-ether5 merupakan trunk port yang melewatkan vlan 10 dan vlan 20

Pada mikrotik-3, interface ether1 access port dengan vlan 10, ether2 access port dengan vlan 20 dan ether5 merupakan trunk port yang melewatkan vlan 10 dan vlan 20

Ok, mulai ya konfigurasi nya

Pertama kita buat dulu trunk port dari masing masing mikrotik

mikrotik-1

/interface vlan add name=vlan-10 vlan-id=10 interface=ether4 disabled=no
/interface vlan add name=vlan-20 vlan-id=20 interface=ether4 disabled=no

mikrotik-2

/interface bridge add name=br-trunk disabled=no
/interface bridge port add interface="ether4" bridge="br-trunk" disabled=no
/interface bridge port add interface="ether5" bridge="br-trunk" disabled=no

mikrotik-3

/interface vlan add name=vlan-10 vlan-id=10 interface=ether5 disabled=no
/interface vlan add name=vlan-20 vlan-id=20 interface=ether5 disabled=no

Kemudian agar dapat forward vlan ke access port kita memerlukan interface bridge, oleh karena itu sekarang kita create interface bridge pada masing-masing mikrotik

mikrotik-1 dan mikrotik-3

/interface bridge add name=br-vlan10 disabled=no
/interface bridge add name=br-vlan20 disabled=no

mikrotik-2

/interface bridge add name=br-vlan10 disabled=no

Selanjutnya tinggal menambahkan port/interface pada masing masing bridge

mikrotik-1 dan mikrotik-3

/interface bridge port add interface="vlan-10" bridge="br-vlan10" disabled=no
/interface bridge port add interface="ether1" bridge="br-vlan10" disabled=no
/interface bridge port add interface="vlan-20" bridge="br-vlan20" disabled=no
/interface bridge port add interface="ether2" bridge="br-vlan20" disabled=no

mikrotik-2

/interface vlan add name=vlan-10 vlan-id=10 interface=br-trunk disabled=no
/interface bridge port add interface="vlan-10" bridge="br-vlan10" disabled=no
/interface bridge port add interface="ether1" bridge="br-vlan10" disabled=no

Sekarang kita coba ping dari masing-masing PC

PC-1

PC1> ping 192.168.10.2
host (192.168.10.2) not reachable

PC1> ping 192.168.10.3
84 bytes from 192.168.10.3 icmp_seq=1 ttl=64 time=9.071 ms
84 bytes from 192.168.10.3 icmp_seq=2 ttl=64 time=8.991 ms
84 bytes from 192.168.10.3 icmp_seq=3 ttl=64 time=12.987 ms
84 bytes from 192.168.10.3 icmp_seq=4 ttl=64 time=13.029 ms
84 bytes from 192.168.10.3 icmp_seq=5 ttl=64 time=13.767 ms

PC1> ping 192.168.10.4
84 bytes from 192.168.10.4 icmp_seq=1 ttl=64 time=21.040 ms
84 bytes from 192.168.10.4 icmp_seq=2 ttl=64 time=18.381 ms
84 bytes from 192.168.10.4 icmp_seq=3 ttl=64 time=21.181 ms
84 bytes from 192.168.10.4 icmp_seq=4 ttl=64 time=23.791 ms
84 bytes from 192.168.10.4 icmp_seq=5 ttl=64 time=17.790 ms

PC1> ping 192.168.10.5
host (192.168.10.5) not reachable

PC-2

PC2> ping 192.168.10.1
host (192.168.10.1) not reachable

PC2> ping 192.168.10.3
host (192.168.10.3) not reachable

PC2> ping 192.168.10.4
host (192.168.10.4) not reachable

PC2> ping 192.168.10.5
84 bytes from 192.168.10.5 icmp_seq=1 ttl=64 time=18.044 ms
84 bytes from 192.168.10.5 icmp_seq=2 ttl=64 time=8.735 ms
84 bytes from 192.168.10.5 icmp_seq=3 ttl=64 time=12.763 ms
84 bytes from 192.168.10.5 icmp_seq=4 ttl=64 time=23.790 ms
84 bytes from 192.168.10.5 icmp_seq=5 ttl=64 time=22.306 ms

PC-3

PC3> ping 192.168.10.1
84 bytes from 192.168.10.1 icmp_seq=1 ttl=64 time=11.764 ms
84 bytes from 192.168.10.1 icmp_seq=2 ttl=64 time=15.806 ms
84 bytes from 192.168.10.1 icmp_seq=3 ttl=64 time=12.721 ms
84 bytes from 192.168.10.1 icmp_seq=4 ttl=64 time=14.775 ms
84 bytes from 192.168.10.1 icmp_seq=5 ttl=64 time=7.756 ms

PC3> ping 192.168.10.2
host (192.168.10.2) not reachable

PC3> ping 192.168.10.4
84 bytes from 192.168.10.4 icmp_seq=1 ttl=64 time=3.009 ms
84 bytes from 192.168.10.4 icmp_seq=2 ttl=64 time=17.801 ms
84 bytes from 192.168.10.4 icmp_seq=3 ttl=64 time=16.844 ms
84 bytes from 192.168.10.4 icmp_seq=4 ttl=64 time=13.810 ms
84 bytes from 192.168.10.4 icmp_seq=5 ttl=64 time=11.793 ms

PC3> ping 192.168.10.5
host (192.168.10.5) not reachable

PC-4

PC4> ping 192.168.10.1
84 bytes from 192.168.10.1 icmp_seq=1 ttl=64 time=9.025 ms
84 bytes from 192.168.10.1 icmp_seq=2 ttl=64 time=21.879 ms
84 bytes from 192.168.10.1 icmp_seq=3 ttl=64 time=22.862 ms
84 bytes from 192.168.10.1 icmp_seq=4 ttl=64 time=6.016 ms
84 bytes from 192.168.10.1 icmp_seq=5 ttl=64 time=19.788 ms

PC4> ping 192.168.10.2
host (192.168.10.2) not reachable

PC4> ping 192.168.10.3
84 bytes from 192.168.10.3 icmp_seq=1 ttl=64 time=10.021 ms
84 bytes from 192.168.10.3 icmp_seq=2 ttl=64 time=13.730 ms
84 bytes from 192.168.10.3 icmp_seq=3 ttl=64 time=12.736 ms
84 bytes from 192.168.10.3 icmp_seq=4 ttl=64 time=12.767 ms
84 bytes from 192.168.10.3 icmp_seq=5 ttl=64 time=14.762 ms

PC4> ping 192.168.10.5
host (192.168.10.5) not reachable

PC-5

PC5> ping 192.168.10.1
host (192.168.10.1) not reachable

PC5> ping 192.168.10.2
84 bytes from 192.168.10.2 icmp_seq=1 ttl=64 time=22.718 ms
84 bytes from 192.168.10.2 icmp_seq=2 ttl=64 time=16.726 ms
84 bytes from 192.168.10.2 icmp_seq=3 ttl=64 time=22.826 ms
84 bytes from 192.168.10.2 icmp_seq=4 ttl=64 time=17.921 ms
84 bytes from 192.168.10.2 icmp_seq=5 ttl=64 time=19.048 ms

PC5> ping 192.168.10.3
host (192.168.10.3) not reachable

PC5> ping 192.168.10.4
host (192.168.10.4) not reachable

PC-1, PC-3 dan PC-4 dapat berkomunikasi karena pada Vlan yang sama yaitu Vlan 10

PC-2 dan PC-5  dapat berkomunikasi karena pada Vlan sama yaitu Vlan 20

Sedangkan pada PC yang beda Vlan tidak bisa berkomunikasi

 

Have any Question or Comment?

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.